Skip to content

Client-side RT log files

This page describes client-side RT log files created when external clients publish data via RT, and explains when these logs grow.

KX Sensors 3.0 introduces RT as the means for external clients to publish data. This means that data is persisted to the local client-side disk by RT. Log files are truncated to a size of 0 bytes once all the data inside them is confirmed to have been sequenced by the RT cluster.

In instances where data continues to be published by the client but isn't being sent to the target, or there's a failure in sequencing, the client's local RT logs continue to grow until the condition is resolved. This can occur if you shut down KX Sensors without first shutting down ingestion clients. Client-side disks should be correctly sized (based on outage SLAs) and monitored to account for the expected ingestion rates and potential disruptions to data transfer, to ensure that the client doesn't run out of disk space.

Warning

Don't manually delete client-side RT logs without careful consideration, and without either performing a hard reset on the RT cluster receiving the data or restarting the client with a new name. Deleting the data manually without a hard reset of the RT cluster results in an error due to a mismatch between the RT logs on the client and server, surfaced with the following error:

Invalid Publishing directory, was it deleted by mistake? Please enter a different Client and restart the SDL with the new client

If client-side RT files aren't required for reliability purposes, the RT cluster receiving data from the external client can be configured in bridge mode by setting the bridge parameter to true in stream.yaml.

Next steps